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corrective active action taken to ensure that objectives are achieved.  This is the function of 

project control.  

Measurement of the actual achievement and comparison with the original plan is 

therefore an essential feature of an effective control system. The sequence of instruction, 

execution, measurement, feedback and. correction is fundamental to control theory. 

The management of the project is therefore a continuous process involving both planning 

and control. While the planning can be done at leisure, the control phase is carried out under 

continuous pressure. 

The continuous recycling of information helps comparing with the original. Plan and in 

cases of deviation (in majority of the cases deviations do, occur as it is very rare that plan targets 

are fulfilled exactly) it becomes necessary to reschedule the plan. This involves considerable work 

even in smaller projects. In the case of large projects involving several activities, a computer 

becomes an invaluable tool. 

Project control in action: The steps involved in project control are: 

1. Fixing up the review period 

2. Obtaining progress information 

3. Comparing actual progress with the schedule 

4. Taking appropriate corrective action when required. 

 

Fixing up the review period : How often the project is to be reviewed depends upon a large 

number of factors and there can be no standard rule or practice about this. The frequency of 

reviewing however will depend upon the type of project, its overall duration and the degree of 

uncertainty involved. 

For the average project, a fortnightly review should be sufficient in the normal course but 

in the case of rapidly changing projects, higher frequency of reviewing is necessary to have close 

control. Projects of the same overall duration using 3 time estimates (PERT system) for activities 

require greater frequency of reviewing than those using single time estimates (CPM system) for 

activities. The interval between reviews may change depending on the management needs. 

 

Obtaining progress information: For obtaining progress, a form shown below is normally 

used. The basic information required refers to activities just started, activities completed, and 

progress on current activities. While the information regarding first two can be given precisely, 

the last may best be quantified by estimating the comp1etion date. 
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Progress Report 

Project  For delayed activity 

Activity Duration Scheduled date Actual date Expected date Remarks 

  Start Finish Start Finish Start Finish 

         

 

 

 

 

 

 

 

 

 

 

Comparing actual progress with the schedule: The actual progress is transferred either on 

to the network or to the scheduling table so that it can be compared with the schedule to identify 

deviations.  

Taking appropriate corrective action when required: Obtaining progress information and 

identification of deviations alone are of little value without effective follow up. If a delay occurs in 

a non-critical activity, corrective action will usually be limited to rescheduling the following 

activities. If a delay occurs in one of the critical activities, corrective action would include adding 

additional resources from non-critical to critical jobs, rescheduling of series operations in parallel 

etc. If the time cannot be made up by any of these methods, completion of the project will be 

delayed. 

Based on the corrective action taken, fresh schedules are prepared for the following 

week/fortnight and the control cycle consisting of execution, measurement, feedback correction 

and instruction repeats itself. 

Frequency of updating: There is no standard practice regarding the frequency of updating. 

Updating may be undertaken at regular intervals or whenever the situation warrants it. Updating 

should be done whenever major changes occur that will affect project completion date or cause a 

shift in the critical path, or when the impact of changes on the schedule cannot be readily noticed 

by inspecting the network. 
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Overview of Microsoft Project 
 

� Start MS Project 

• Double-click on the MS Project icon. 

 Or 

• Click the Start button, select Programs, select the Project icon. 

� Using Help 

• Click on the Help menu and select Microsoft Project Help or press 

[F1]. 

• The Project Help task pane will open on the right of the screen 

enabling you to search for assistance on a specific topic. 

 

The Office Assistant 

The office assistant offers tips on what you are doing, can answer questions you have, 

and enables you to ask questions in a non-jargon way.  The office assistant usually 

appears as an animated paper clip. 

 

� To Use the Office Assistant 

 

• Click on the Help menu and select Show the Office Assistant 

• Type in the topic required. 

• Click on Search 

 
Note:  When performing certain actions (especially for the first time) the Office Assistant will 

appear automatically with a list of help options relative to what you are doing. 

 

As well as offering help, the Office Assistant also offers tips on quick or short cuts for the 

features you are using.  If the Office Assistant is visible a light bulb appears next to the 

paper clip.  Otherwise a light bulb appears on the tool on the toolbar. 
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MS Project - The Screen 
 

 
 

 

The Menus: Always displayed, some options depend on the selected view. 

Tool Bars: Buttons provide quick access to the most common commands, 
The bars can be customised 

Task Pane With options to help when ‘Getting Started’. Other task panes are 
available. 

Entry Bar: The entry point for text with outlining buttons. 

Status Bar: At the bottom of the screen showing the current status. 

Scroll Bars: When using a mouse to scroll the views and to move the 
boundary between two views.  

Working Area: The area for 1 or 2 views, the size of each can be adjusted. 
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Elements of the Default View 
 

The default Project view is the Gantt Chart view, as displayed below. This view is used 

extensively in Microsoft Project. The Gantt Chart consists of a Gantt table and a Gantt 

bar chart. The divider bar separates the two and can be repositioned to display more of 

the table or more of the chart. The Gantt table consists of rows and columns. Just like on 

a spreadsheet, the intersection of a row and a column is called a cell. The Gantt bar chart 

graphically displays your schedule on a time line. 

 

The status bar displays the current mode of operation and warning messages and 

indicates when special key control modes, such as Num Lock mode, are on. The entry bar 

contains an Entry box where all information is input. The default toolbars are the 

Standard toolbar, Formatting toolbar and the Project Guide. Other toolbars can be 

displayed by choosing Toolbars from the View menu. 

 

 

 

 

Views and Tables 
 

A view is the format of the way that project data is displayed on the screen and there are 

a considerable number of different permutations that can be used. 

 

The View Menu is the first place where the view that is required is selected. The basic 

selection is between a Chart, a Form, or a Sheet.  Some of the options in this menu can 

provide a split view to show two different displays for the same Task or Resource. 
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You can also use the View bar, located vertically on the left of the default view (if it is 

active). To activate/deactivate the View Bar, select View, View Bar. 

 

As well as the standard views achieved with the View menu or View bar, you can select 

More Views to see more detailed and complex views and forms. 
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The table below describes some of the main views in Project. 

 

Calendar: Shows the view in the form of a calendar. 

Gantt Chart: A diagrammatic view of the Tasks and their time scale.  This 
chart can also show the relationship between Tasks and the 
Critical Path.  It usually shows the task entry form alongside 
the Gantt chart. 

Network Diagram 
Chart: 

 Network Diagram is an acronym for Programme Evaluation 
Review Technique.  This view represents each Task as a 
box with relevant information within it.  The layout of the 
boxes on the chart and the lines that link the boxes 
represent the structure of the project. 

Task Usage: The Task Usage view displays project tasks with their 
assigned resources grouped underneath them. 

Tracking Gantt: The Tracking Gantt view displays two task bars, one on top 
of the other, for each task. The lower bar shows baseline 
start and finish dates, and the upper bar shows scheduled 
start and finish dates (or if the task has already started, 
meaning that the percentage complete is greater than zero, 
the upper bar shows the actual start and finish dates). 

Resource Graph:  A graphical representation of a single resource and its 
utilisation. 

Resource Sheet:  A list of all the resources for the project. 

Resource Usage:  This is a view that shows the use in hours per day for each 
resource. 

More Views: Allows the showing of combination views as well as details 
of a single Task 

Table:(Entry): Changes the form alongside the Gantt chart. 

Reports: Takes you into Report Wizard. 

Toolbars: Allows you to change the Toolbar display. 

View Bar: Activates the View bar, located vertically on the left of the 
screen. 

Zoom: Changes the amount of information you can see on screen, 
from days to years. 
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The Tracking Gantt View 
When you initially set up your project with tasks and dates, and then save the project with 

a baseline, the Tracking Gantt view displays those tasks as shown in the following 

example. 

 

 
 

The baseline bars and the scheduled or actual bars are synchronized. However, if the start 

date of task slips by, say, 2 days, the red scheduled bar will extend 2 days beyond the 

lower baseline bar. 

 

Because the tasks are linked, the slipping of task 2 will cause a ripple effect, making its 

successor tasks slip by 2 days as well. 

 

You can use the Tracking Gantt view to: 

 

• See how tasks progress across time and evaluate the slippage of 

tasks. You can track progress by comparing baseline and scheduled 

or actual start and finish dates and by checking the completion 

percentage of each task. 

• View tasks graphically while still having access to detailed 

information about the tasks. 

• Create a project by entering tasks and the amount of time each task 

will take. 

• Establish sequential dependencies between tasks by linking them. 

When you link tasks, you can see how a change in the duration of 

one task affects the start and finish dates of other tasks and the 

project finish date. 

• Assign personnel and other resources to tasks.  

MS Project - Menus 

The File Menu 

The File menu is typical of the windows environment. The command which pertains to 

MS Project is: 
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 Properties: Provides basic information on the Project. 

The Edit Menu 

The Edit menu is also typical of the windows environment. Commands which pertain to 

MS Project include: 

 

 Link Tasks: Create links between tasks. 

 Unlink Tasks: Break an existing link. 

 Go To: Go to a task or resource. (Depends on view.) 

The Insert Menu 

Among other things allows you to insert new rows for tasks or columns for information. 

You can also go to the Task information dialog box to add more detailed information to 

the current task. 

The Format Menu 

This changes dramatically when different views are selected. The following are the 

principal selections. 

 

For a Network Diagram the choices are: 

Text Styles: Modifies the size, and type of the selected text. 

Box Styles: Changes the appearance of the Network Diagram 

boxes. 

Layout: Allows you to customise the way links are shown. 

Layout Now: Redraws to show changes made to links etc. 

For the GANTT chart the choices are: 

Font: Used to change the font. 

Bar: Change the selected Gantt Bar style 

Timescale: Allows you to set the displayed time at anything 

from years to minutes. 

Gridlines: Allows you to display or hide Gridlines and change 

their appearance. 

Gantt Chart Wizard: Takes you through the programs method of setting 

up your Gantt chart. 

Text Styles: Change the font, size and colours 

Bar Styles: Change all Gantt bars. 

Details: Details of the Gantt chart 

Layout: Change the way the bars are displayed including 

links. 
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The Tools Menu 

The main choices here are Change Working Time, Tracking and Multiple Projects. 

 Assign Resources: Apply various filters to the tasks. 

 Level Resources: Shows resource levelling 

information 

 Change Working Time: Format a new Calendar. 

 Tracking: Check the progress. 

 Links Between Projects: Set up sub projects and links. 

The Project Menu 

This menu is for retrieving information on the project and its components. Some of the 

options launch sub menus. The commands are fairly self-explanatory and will become 

clearer later in this course. 

There are also the usual Window and Help options. 

 

You will find that the menu choices may change depending on the view selected. If 

this happens it simply means that the option you wanted is not available for that 

view. 

MS Project - The Tool Bars 
The Buttons provide quick access to some of the commands available from the pull down 

menus.  The default arrangement of the toolbars is the Standard and Formatting bars 

active. 

 

The formatting bar is virtually identical to the same thing in other Office applications, 

except it has the Outline tools attached to it. These tools are for promoting and demoting 

tasks, Collapsing and expanding sub tasks plus the usual Text format and alignment 

buttons. 

 

 
 

The Standard toolbar contains the following buttons: 
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• Create a New blank file. 

• Open an existing File. 

• Save the current file 

• Perform a File Search 

• Print the active View 

• Print Preview the active view 

• Spell check the selection. 

• Cut the highlighted section to the 

Clipboard 

• Copy the highlighted section to the 

Clipboard 

• Paste from the Clipboard. 

• Format Painter. 

• Undo the previous action. 

• Insert a hyperlink Launch the Web 

toolbar. 

• Link the selected tasks with a 

Finish-to-Start relationship 

• Unlink the selected tasks. 

• Split the selected tasks 

• Open the Task Information 

dialog box. 

• Attach a note to the current 

task. 

• Add Resources. 

• Publish Information. 

• Group Information. 

• Zoom in. 

• Zoom out. 

• Goto selected task. 

• Copy a static Picture so it can 

be used in another 

application. 

• Display the Office Assistant 

 

� Loading and Viewing a Project 

• Select File, Open to open any project file. 

• Press [Ctrl-Home] and [Alt-Home] to go to the start of the project. 

• Use the scroll tools to see the project progress. 

• Use the mouse to change the size of the various windows. 

• Alter the time scale with View, Zoom. 

� Change the View 

• Click on the View menu.  
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• Choose each of the top five and note the different screens. 

• Select View, Gantt Chart to return to the original view. 

• Move the mouse to the central vertical bar on the screen when it will 

change to a double line with a double-headed arrow 

• Click and hold the left button and drag left to see more of the Gantt 

Chart. 

• Repeat but drag right to see more of the Entry Table. 

� Change the Project Start Date 

• Select Project, Project Information from the menus. 

• Change the project Start Date. 

 

• Click Add and click OK and examine the views again. 

• Select Tools, Tracking, Update Project to see project progress so 

far. 

 

� Exit Project 

• Select File, Close to close the existing project file. 
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Task Entry and Linking 

Entering Tasks 
 

This is the main activity in setting up a new project.  The tasks which have been 

identified at the Design Stage must be entered. 

 

The system will hold task information in a task database, which we cannot access directly 

but is used by the system whenever we view task data.  This is one of two databases the 

system uses the other being the resource database. 

 

It is important to understand that the system checks the data that it holds and where the 

data does not cross check then the system will generally update the database to make it 

right. It is important to keep an eye on this process; this will be discussed in a later 

section. 

 

As each entry is made the system will update the appropriate data and views to reflect the 

entries. 

 

The order of entry should be in the logical progression but this is not essential as it can be 

changed. 

 

Normal Task entry will be by using the standard Task Sheet. The Gantt View shows the 

Gantt Chart in the right part of the window with the Task Sheet in the left part. 

The Task Information box/Task Sheet 
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The Task sheet is a view of the selected task with information shown in the columns as 

follows: - 

 

ID: The Task Identification number. 

Name: The Name of the Task. 

Duration: The time the Task will take including the time units. 

Start Date: This is the current Scheduled Start date for the Task. 
Not the Planned or Actual Start. 

Finish Date: The Scheduled Finish date. 

Predecessors: The ID numbers for the preceding Tasks that are linked 
to this Task. 

Resources: The names of the resources performing or used in the 
Task. 

 

 
 

The Task Entry Form 
It is possible to select the Task Entry view to see the Gantt Chart in the upper pane and 

the Task Form in the lower pane. To do this choose View, More Views, Task Entry. 

From the Task Sheet the following entries can be made. 

 

ID: The Task Identification number. 

 

Task Name: The Name of the Task. 
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Duration: The time the Task will take including the time units. 

 

As the entries are made, the Gantt Chart will automatically be updated to display the 

tasks. 

 

 

If using the Task Form it will be possible to enter and/or view the following. 

 

Name: The name of the task 

 

Duration: The length of time the task will take and the units of time. 

 

Fixed: A check box to specify the start date to be fixed. 

 

Start: The scheduled start date, if this is not entered the system will calculate it 

from the data entered and the relationships defined. 

 

Finish: The scheduled finish date, entered or calculated as above. 

 

% Complete: A measure of the completion of the Task if it has been started. 

 

Tables and descriptions 

Resource Table 

 

ID: The identification number of the Resource 

Resource Name: The name of the resource. 

Units The number of units available for the resource. 

Work The amount of work currently assigned to the resource. 

Predecessor Table 

ID The identification number of the Predecessor. 

Predecessor Name: The name of the Predecessor.  If this is not entered the system 

will look it up using the ID number. 

Type: The relationship with the current Task which will be FS, or SS, 

or FF. 

Lag The time delay between the end of the Predecessor the start of 

the Successor. 
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It is not necessary to complete all the fields at entry time, as more information is added so 

the system will update the boxes.  It is only necessary to enter the data that has been 

determined in the design stage. 

 

� To enter task descriptions and durations one cell 
at a time: 

 

• In the Task Name column, select the first available cell and type the 

name of the task. 

• Press TAB 

• In the Duration column, type the value of the duration. If the 

duration is anything other than days, type m for minutes, h for hours, 

or w for weeks. 

• Press ENTER 

• Press LEFT ARROW to return to the Task Name column and repeat 

steps 1 through 4 as required. 

� To enter task descriptions and durations by 
selecting a range: 

 

• Select the first cell (the numbered cell) of the desired range. 

• Drag the mouse through the range of cells you want to include. 

• In the first cell, type the desired information. 

• Press TAB 

• In the Duration column, type the appropriate information. 

• Repeat steps 4 and 5 as required. 

 

Note: Pressing SHIFT+TAB moves to the previous cell without deselecting the range. Clicking 

your mouse inside or outside the range will deselect the range. 
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Other Methods of Adding Tasks 
As a general rule Tasks can be added in any view where the tasks are displayed.  The 

most obvious methods in addition to using the normal Task Entry view are as follows: - 

In the Gantt Chart or the Task Sheet 

An additional task can be added at the end of the list using the Insert, New Task 

command. 

 

Where additional information is required to be entered then this can be done by using the 

Task Information form which is opened by simply double-clicking a task in the task list. 

 

Using the Task Information Form 

It is possible to enter additional tasks using this form but it does not have all the possible 

entry points. The details of this form are included in the description of the Task Entry 

View above. 

Using The Network Diagram Chart 

Additional tasks can be placed within the chart by drawing a box and then entering the 

information within the fields.  The relationship can be also be entered graphically by 

pointing to the Predecessor and dragging a line to the Successor. 

 

Where a relationship needs to be removed, a double click on it will display a box which 

has a delete button in it. 

 

Further time will be spent on this view later. 

 
Note: When you try to make a link that is not logical or possible, Project will warn you about 

this (see illustration below). 

 

 

Add Tasks 
The following tasks can be used as a practical in MS Project. 

 

[This column is for 
your info only] 

Task Duration 

Milestone task Course Development 0d 

Summary task Preparation 1d 
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Sub tasks Install Software 2h 

   ″    ″   Studies and Specifications 1d 

Summary task Section Development  

Sub tasks Section 1  

   ″    ″ Section 2  

   ″    ″ Section 3  

   ″    ″ Section 4  

   ″    ″ Section 5  

   ″    ″ Section 6  

   ″    ″ Section 7  

   ″    ″ Section 8  

 

• Enter the tasks as above. As you enter them Project will enter 1d as 

the default duration. Change this for Install Software. 

Note: By simply setting the Course Development task to zero days. It is given Milestone 

status. 

Linking Tasks 
In order that the system is able to display the overall time aspects of the project, each 

Task must be defined in terms of the Tasks on which it is dependent and in turn those 

Tasks that are dependent on it.  It is also possible to define in what way these 

dependencies exist. 

 

Most associated Tasks will have a straightforward linear relationship. That is, the 

preceding task must finish before the next task can start. This is the Finish to Start 

relationship. 

 

This is not true for all situations, for example if bricks are being made to build a house, 

the building cannot start until some bricks are available but it is not necessary for all the 

bricks to be made before the building can start. The relationship between making the 

bricks and building the house can be described as Start to Start but with a time lag to 

allow for the first batch of bricks to be ready. 

 

An alternative relationship can be Finish to Finish which is true where two tasks must be 

ready at the same time. For example in the preparation of a banquet, the elements of each 

course must be completed at the same time in order that they are at their best. 

To summarise the main three relationships that can happen are as follows: - 

 

• Finish to Start (FS) 
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• Start to Start (SS) 

• Finish to Finish (FF) 

We can also fine tune these relationships by specifying Lag or Lead times as required. 

 

Linking of Tasks can be achieved by making the appropriate entry in any of the task 

views or highlighting the tasks and using the link button on the Tool Bar, or by using the 

Edit, Link Tasks command  

 
Note: You need to highlight the tasks you want to link before trying to link them. Use the 

mouse while holding down the [Ctrl] and/or [Shift] button(s) to do this 

� Links are most clearly shown in the Network 
Diagram  

• Enter some of the links by completing the Predecessor ID in the 

lower pane. 

• Add some of the links by selecting them and using the linking 

button. 

Defining the Summary Tasks 
Microsoft Project provides the ability to structure the tasks by setting different levels of 

tasks and grouping tasks under a summary task. This can be useful where the project has 

a considerable number of tasks; management can be made easier by only viewing and 

reporting on the summary tasks. 

 

 
 

There are five buttons on the far left of the Formatting Toolbar which can be used on a 

single task or group of highlighted tasks. 

 

• Promote the selection to the next higher level 

• Demote the selection to the next lower level 

• Expands a summary task to show its subordinate tasks 

• Collapse a summary task to hide the subordinate tasks 

• Hide assignments 

• Show all subtasks, or those of a particular outline level. 



 

 70

 

� Create Summary Tasks and Link Tasks 

• Select the sub tasks Install Software and Studies and Specification. 

• Indent the tasks to make them sub tasks. 

• While they are still selected link them (chain button or Edit menu). 

• Make Sections 1 to 8 sub tasks and link them. 

 

� Insert Tasks 

If you miss a task from your list you can insert a blank line and type the information. 

 

• Click on Studies and Specifications. 

• Right-click and choose New Task to insert a blank row. 

• Type Backup Installation as the task and set the time to 1h. 

� Add New Tasks 

Having added tasks you can continue adding tasks at the end of your project. 
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• Move to the line below Section 8 and type Slide Development. 

• Set the Duration to 5d. 

• Outdent the task by clicking on the Outdent button. 

• Link it to Section 8. 

• Save your project as Training Course. 

• Save with a baseline. 

� Change Duration 

The default duration is 1day. To change this you can simply overtype with the new value. 

 

• Change the durations for 

each Module to 2d. 

• When the Wizard appears 

READ THE 

INFORMATION then 

click on the OK button. 

• Select all the remaining 

tasks. 

• Open the Task information box. 

• Set the duration to 1.5d 

� Multiple Links 

Tasks can be linked to more than one predecessor. 

 

• Select the task Slide Development, hold down the Ctrl key and 

select the task Module 1. 

• Click on the Link Tasks button. 

• When you get a warning, try to figure out why the link is illogical. 

Look at the Gantt chart if it makes it easier to think. 
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� Save a Baseline 

• Select Tools, Tracking, Save Baseline from the menus. 

• Click on the Save baseline radio button. 

• Click on the OK button. 

 

 

 


